db-move: moved linux from [testing] to [core] (x86_64)
[arch-packages.git] / libgsf / repos / extra-x86_64 / PKGBUILD
blob3a025118999624597b910b775453471aaf191cc7
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
3 # Contributor: Sarah Hay <sarahhay@mb.sympatico.ca>
5 pkgname=libgsf
6 pkgver=1.14.50
7 pkgrel=1
8 arch=(x86_64)
9 pkgdesc="An extensible I/O abstraction library for dealing with structured file formats"
10 url="https://gitlab.gnome.org/GNOME/libgsf"
11 license=(GPL LGPL)
12 depends=(libxml2 gdk-pixbuf2 bzip2)
13 makedepends=(gobject-introspection git gtk-doc autoconf-archive)
14 checkdepends=(perl-xml-parser unzip valgrind) 
15 provides=(libgsf-1.so)
16 options=(debug)
17 _commit=3f6b8dc6f2ba395eeb0dc3c2ebc60c14105be3e1  # tags/LIBGSF_1_14_50^0
18 source=("git+https://gitlab.gnome.org/GNOME/libgsf.git#commit=$_commit")
19 sha256sums=('SKIP')
21 pkgver() {
22   cd libgsf
23   git describe --tags | sed 's/^LIBGSF_//;s/_/./g;s/[^-]*-g/r&/;s/-/+/g'
26 prepare() {
27   cd libgsf
28   NOCONFIGURE=1 ./autogen.sh
31 build() {
32   cd libgsf
33   ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
34     --disable-static --enable-introspection --enable-gtk-doc
35   sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
36   make
39 check() {
40   cd libgsf
41   make check
44 package_libgsf() {
45   cd libgsf
46   make DESTDIR="$pkgdir" install
49 # vim:set sw=2 et: