1 # Maintainer: Eric BĂ©langer <eric@archlinux.org>
3 pkgname=bash-completion
6 pkgdesc='Programmable completion for the bash shell'
8 url='https://github.com/scop/bash-completion'
11 options=(!emptydirs !makeflags)
12 source=($url/releases/download/$pkgver/$pkgname-$pkgver.tar.xz
13 $pkgname-drill.patch::https://github.com/scop/bash-completion/commit/cbec56cfd543.patch)
14 validpgpkeys=(A558062B6D5DA1347CD468D52B0AE2C1B09B07CB)
15 sha256sums=('73a8894bad94dee83ab468fa09f628daffd567e8bef1a24277f1e9a0daf911ac'
16 '84563efa872e56b293a76abb2e5ec70e845f0fa1a22b8d33d2d4a6fa49b25b5a')
20 patch -Np1 -i ../$pkgname-drill.patch
25 ./configure --prefix=/usr --sysconfdir=/etc
31 make DESTDIR="$pkgdir" install
33 # bash-completion is sourced in /etc/bash.bashrc so that non-bash shell don't source it
34 rm "$pkgdir/etc/profile.d/bash_completion.sh"
36 # remove Slackware's makepkg completion
37 rm "$pkgdir/usr/share/bash-completion/completions/makepkg"