OCaml 5.0.0 rebuild: Fix Pervasives deprecation
[arch-packages.git] / gnome-2048 / trunk / PKGBUILD
blob35397389722625008a56917bfd129e75b31bc2a7
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
3 pkgname=gnome-2048
4 pkgver=3.38.2
5 pkgrel=2
6 pkgdesc="Obtain the 2048 tile"
7 url="https://wiki.gnome.org/Apps/2048"
8 arch=(x86_64)
9 license=(GPL3)
10 depends=(
11   clutter-gtk
12   libgee
13   libgnome-games-support
15 makedepends=(
16   appstream-glib
17   git
18   meson
19   vala
20   yelp-tools
22 groups=(gnome-extra)
23 _commit=82f155f326a9e1973d7283bfa3f7cbb756a9984a  # tags/3.38.2^0
24 source=("git+https://gitlab.gnome.org/GNOME/gnome-2048.git#commit=$_commit")
25 b2sums=('SKIP')
27 pkgver() {
28   cd $pkgname
29   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
32 prepare() {
33   cd $pkgname
35   # Fix build with newer meson
36   git cherry-pick -n 194e22699f7166a016cd39ba26dd719aeecfc868
39 build() {
40   arch-meson $pkgname build
41   meson compile -C build
44 check() {
45   meson test -C build --print-errorlogs
48 package() {
49   meson install -C build --destdir "$pkgdir"
52 # vim:set sw=2 sts=-1 et: