OCaml 5.0.0 rebuild: Fix Pervasives deprecation
[arch-packages.git] / iagno / trunk / PKGBUILD
blob0747b3e853ae190622257d1bc4566b519947fcd1
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
4 pkgname=iagno
5 pkgver=3.38.1+r57+gd147e1a
6 pkgrel=1
7 pkgdesc="Dominate the board in a classic version of Reversi"
8 url="https://wiki.gnome.org/Apps/Iagno"
9 arch=(x86_64)
10 license=(GPL)
11 depends=(gtk3 gsound librsvg)
12 makedepends=(meson gobject-introspection yelp-tools appstream-glib vala git)
13 groups=(gnome-extra)
14 _commit=d147e1a30189716d654e9b9e9aba2112d35b7dc6  # master
15 source=("git+https://gitlab.gnome.org/GNOME/iagno.git#commit=$_commit")
16 sha256sums=('SKIP')
18 pkgver() {
19   cd $pkgname
20   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
23 prepare() {
24   cd $pkgname
27 build() {
28   arch-meson $pkgname build
29   meson compile -C build
32 check() {
33   meson test -C build --print-errorlogs
36 package() {
37   meson install -C build --destdir "$pkgdir"
40 # vim:set sw=2 sts=-1 et: