OCaml 5.0.0 rebuild: Fix Pervasives deprecation
[arch-packages.git] / perl-config-simple / trunk / PKGBUILD
blob4dbb0786f916a4166c90dcb3a60b470d40e87a4e
1 # Maintainer: Florian Pritz <bluewind@xinu.at>
3 pkgname=perl-config-simple
4 pkgver=4.59
5 pkgrel=15
6 pkgdesc="Simple configuration file class to create and read config files"
7 arch=(any)
8 license=(PerlArtistic GPL)
9 options=(!emptydirs)
10 depends=('perl')
11 url="https://search.cpan.org/~sherzodr/Config-Simple"
12 source=("https://search.cpan.org/CPAN/authors/id/S/SH/SHERZODR/Config-Simple-${pkgver}.tar.gz")
13 sha256sums=('cb78a975ad8463f992f35f392227aaf188d533c9092373742b3c2bb592781054')
15 build() {
16   export PERL_MM_USE_DEFAULT=1 PERL5LIB=""                 \
17     PERL_AUTOINSTALL=--skipdeps                            \
18     PERL_MM_OPT="INSTALLDIRS=vendor"     \
19     PERL_MB_OPT="--installdirs vendor" \
20     MODULEBUILDRC=/dev/null
22   cd "${srcdir}/Config-Simple-${pkgver}"
23   /usr/bin/perl Makefile.PL
24   make
27 check() {
28   export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
29   cd "${srcdir}/Config-Simple-${pkgver}"
30   make test
33 package() {
34   cd "$_distdir"
35   cd "${srcdir}/Config-Simple-${pkgver}"
36   make DESTDIR="$pkgdir" install
37   find "$pkgdir" -name .packlist -o -name perllocal.pod -delete