OCaml 5.0.0 rebuild: Fix Pervasives deprecation
[arch-packages.git] / qt5-svg / trunk / PKGBUILD
blobcaf0b9e32ed8af3ae0b1728e8bd5d742889d5533
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Maintainer: Antonio Rojas <arojas@archlinux.org>
3 # Contributor: Andrea Scarpino <andrea@archlinux.org>
5 pkgname=qt5-svg
6 _basever=5.15.9
7 pkgver=5.15.9+kde+r8
8 pkgrel=1
9 _commit=837b5163e17edbd3a9f098e9a1ab73febab419b4
10 arch=('x86_64')
11 url='https://www.qt.io'
12 license=('GPL3' 'LGPL3' 'FDL' 'custom')
13 pkgdesc='Classes for displaying the contents of SVG files'
14 depends=('qt5-base')
15 makedepends=('git')
16 groups=('qt' 'qt5')
17 _pkgfqn=${pkgname/5-/}
18 source=(git+https://invent.kde.org/qt/qt/$_pkgfqn#commit=$_commit)
19 sha256sums=('SKIP')
21 pkgver() {
22   cd $_pkgfqn
23   echo "$_basever+kde+r"`git rev-list --count v$_basever-lts-lgpl..$_commit` | sed -e 's|+kde+r0||'
26 prepare() {
27   mkdir -p build
30 build() {
31   cd build
33   qmake ../${_pkgfqn}
34   make
37 package() {
38   cd build
39   make INSTALL_ROOT="$pkgdir" install
41   # Drop QMAKE_PRL_BUILD_DIR because reference the build dir
42   find "$pkgdir/usr/lib" -type f -name '*.prl' \
43     -exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;
45   install -d "$pkgdir"/usr/share/licenses
46   ln -s /usr/share/licenses/qt5-base "$pkgdir"/usr/share/licenses/${pkgname}