db-move: moved grilo-plugins from [staging] to [testing] (x86_64)
[arch-packages.git] / gd / trunk / PKGBUILD
blob172a7ff0a29cda1cb4dc0ca0d7ea1b1ae9fe071e
1 # Maintainer: Pierre Schmitz <pierre@archlinux.de>
3 pkgname=gd
4 pkgver=2.3.3
5 pkgrel=6
6 pkgdesc="Library for the dynamic creation of images by programmers"
7 arch=('x86_64')
8 url="https://libgd.github.io/"
9 license=('custom')
10 depends=('fontconfig' 'libxpm' 'libwebp' 'libavif' 'libheif')
11 optdepends=('perl: bdftogd script')
12 checkdepends=('ttf-liberation')
13 source=("https://github.com/libgd/libgd/archive/${pkgname}-${pkgver}.tar.gz"
14         'https://github.com/libgd/libgd/commit/bdc281eadb1d58d5c0c7bbc1125ee4674256df08.patch')
15 sha256sums=('24429f9d0dbe0f865aaa4b1a63558242396ba9134e6cfd32ca5e486a84483350'
16             '1e7bdb17e76ad6b1384222b449b9011ee131d3e1f105f9b30495a9c34b2cd5eb')
18 prepare() {
19   cd libgd-${pkgname}-${pkgver}
21   # Re-add macros that are used in PHP
22   # See https://github.com/php/php-src/pull/7490
23   patch -p1 -R -i "$srcdir/bdc281eadb1d58d5c0c7bbc1125ee4674256df08.patch"
26 build() {
27   cd libgd-${pkgname}-${pkgver}
29   ./bootstrap.sh
30   ./configure \
31     --prefix=/usr \
32     --disable-rpath
33   make
36 check() {
37   cd libgd-${pkgname}-${pkgver}
39   TMP=$(mktemp -d) make check
42 package() {
43   cd libgd-${pkgname}-${pkgver}
45   make DESTDIR="${pkgdir}" install
46   install -D -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"