1 # Maintainer: Pierre Schmitz <pierre@archlinux.de>
6 pkgdesc="Library for the dynamic creation of images by programmers"
8 url="https://libgd.github.io/"
10 depends=('fontconfig' 'libxpm' 'libwebp' 'libavif' 'libheif')
11 optdepends=('perl: bdftogd script')
12 checkdepends=('ttf-liberation')
13 source=("https://github.com/libgd/libgd/archive/${pkgname}-${pkgver}.tar.gz"
14 'https://github.com/libgd/libgd/commit/bdc281eadb1d58d5c0c7bbc1125ee4674256df08.patch')
15 sha256sums=('24429f9d0dbe0f865aaa4b1a63558242396ba9134e6cfd32ca5e486a84483350'
16 '1e7bdb17e76ad6b1384222b449b9011ee131d3e1f105f9b30495a9c34b2cd5eb')
19 cd libgd-${pkgname}-${pkgver}
21 # Re-add macros that are used in PHP
22 # See https://github.com/php/php-src/pull/7490
23 patch -p1 -R -i "$srcdir/bdc281eadb1d58d5c0c7bbc1125ee4674256df08.patch"
27 cd libgd-${pkgname}-${pkgver}
37 cd libgd-${pkgname}-${pkgver}
39 TMP=$(mktemp -d) make check
43 cd libgd-${pkgname}-${pkgver}
45 make DESTDIR="${pkgdir}" install
46 install -D -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"