db-move: moved grilo-plugins from [staging] to [testing] (x86_64)
[arch-packages.git] / gperftools / trunk / PKGBUILD
blob466f1e2e4280d1fbb8631107ae28313eec5b4c20
1 # Maintainer: Dave Reisner <dreisner@archlinux.org>
2 # Contributor: Alexander Rødseth <rodseth@gmail.com>
3 # Contributor: Thomas Jost <schnouki@schnouki.net>
4 # Contributor: JaDa <jada@archlinux.us>
5 # Contributor: Joaquim Pedro <osmano807@gmail.com>
6 # Contributor: Jan Rüegg <rggjan@gmail.com>
8 pkgname=gperftools
9 pkgver=2.10
10 pkgrel=1
11 pkgdesc="Fast, multi-threaded malloc and nifty performance analysis tools"
12 arch=('x86_64')
13 url="https://github.com/gperftools/gperftools"
14 license=('BSD')
15 depends=('perl' 'libunwind' )
16 provides=('libtcmalloc.so'
17           'libprofiler.so'
18           'libtcmalloc_debug.so'
19           'libtcmalloc_and_profiler.so'
20           'libtcmalloc_minimal.so'
21           'libtcmalloc_minimal_debug.so')
22 optdepends=('graphviz: pprof graph generation'
23             'gv: pprof postscript generation')
24 source=(https://github.com/gperftools/gperftools/releases/download/$pkgname-$pkgver/$pkgname-$pkgver.tar.gz)
25 sha256sums=('83e3bfdd28b8bcf53222c3798d4d395d52dadbbae59e8730c4a6d31a9c3732d8')
27 build() {
28   cd $pkgname-$pkgver
30   ./configure --prefix=/usr --enable-frame-pointers --enable-libunwind
31   make
34 package() {
35   cd $pkgname-$pkgver
37   make DESTDIR="$pkgdir" install
38   install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"