1 # Maintainer: Dave Reisner <dreisner@archlinux.org>
2 # Contributor: Alexander Rødseth <rodseth@gmail.com>
3 # Contributor: Thomas Jost <schnouki@schnouki.net>
4 # Contributor: JaDa <jada@archlinux.us>
5 # Contributor: Joaquim Pedro <osmano807@gmail.com>
6 # Contributor: Jan Rüegg <rggjan@gmail.com>
11 pkgdesc="Fast, multi-threaded malloc and nifty performance analysis tools"
13 url="https://github.com/gperftools/gperftools"
15 depends=('perl' 'libunwind' )
16 provides=('libtcmalloc.so'
18 'libtcmalloc_debug.so'
19 'libtcmalloc_and_profiler.so'
20 'libtcmalloc_minimal.so'
21 'libtcmalloc_minimal_debug.so')
22 optdepends=('graphviz: pprof graph generation'
23 'gv: pprof postscript generation')
24 source=(https://github.com/gperftools/gperftools/releases/download/$pkgname-$pkgver/$pkgname-$pkgver.tar.gz)
25 sha256sums=('83e3bfdd28b8bcf53222c3798d4d395d52dadbbae59e8730c4a6d31a9c3732d8')
30 ./configure --prefix=/usr --enable-frame-pointers --enable-libunwind
37 make DESTDIR="$pkgdir" install
38 install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"