archrelease: copy trunk to extra-x86_64
[arch-packages.git] / efibootmgr / trunk / PKGBUILD
blobdb643318352dfd1712ef82299aa831e308e7b365
1 # Maintainer: David Runge <dvzrv@archlinux.org>
2 # Contributor: Tobias Powalowski <tpowa@archlinux.org>
3 # Contributor: Murtuza Akhtari <inxsible at gmail dot com>
4 # Contributor: Keshav Amburay <(the ddoott ridikulus ddoott rat) (aatt) (gemmaeiil) (ddoott) (ccoomm)>
6 # upstream only signs commits
7 _commit=e067160ecef8208e1944002e5d50b275733211fb # 17
8 pkgname=efibootmgr
9 pkgver=17
10 pkgrel=2
11 pkgdesc="Linux user-space application to modify the EFI Boot Manager"
12 arch=('x86_64')
13 url="https://github.com/rhboot/efibootmgr"
14 license=('GPL2')
15 depends=('glibc' 'popt')
16 makedepends=('efivar' 'git')
17 source=("${pkgname}::git+https://github.com/rhboot/efibootmgr#tag=${pkgver}?signed")
18 sha512sums=('SKIP')
19 validpgpkeys=('B00B48BC731AA8840FED9FB0EED266B70F4FEF10') # Peter Jones <pjones@redhat.com>
21 prepare() {
22   mv -v "${pkgname}" "${pkgname}-${pkgver}"
23   cd "${pkgname}-${pkgver}"
24   # removing hotfix function declaration:
25   # https://github.com/rhboot/efibootmgr/issues/128
26   sed -e '/extern int efi_set_verbose/d' -i "src/${pkgname}.c"
29 build() {
30   cd "${pkgname}-${pkgver}"
31   make libdir='/usr/lib' sbindir='/usr/bin' EFIDIR='arch'
34 package() {
35   depends+=('libefiboot.so' 'libefivar.so')
36   cd "${pkgname}-${pkgver}"
37   make DESTDIR="${pkgdir}" \
38        libdir='/usr/lib' \
39        sbindir='/usr/bin' \
40        EFIDIR='arch' \
41        install
42   install -vDm 644 {AUTHORS,README,README.md,TODO} \
43     -t "${pkgdir}/usr/share/doc/${pkgname}"