archrelease: copy trunk to extra-x86_64
[arch-packages.git] / gsound / repos / extra-x86_64 / PKGBUILD
blobe1c69ff2189a3169113193a7f5c2dea096090781
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
4 pkgname=gsound
5 pkgver=1.0.3
6 pkgrel=2
7 pkgdesc="Small library for playing system sounds"
8 url="https://wiki.gnome.org/Projects/GSound"
9 license=(LGPL)
10 arch=(x86_64)
11 depends=(glib2 libcanberra)
12 makedepends=(gobject-introspection vala git gtk-doc meson)
13 options=(debug)
14 _commit=95d36d60cf53e0e7c5d5325e0f1f4fc765a611ae  # tags/1.0.3^0
15 source=("git+https://gitlab.gnome.org/GNOME/gsound.git#commit=$_commit")
16 sha256sums=('SKIP')
18 pkgver() {
19   cd gsound
20   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
23 prepare() {
24   cd gsound
27 build() {
28   arch-meson gsound build -D gtk_doc=true
29   meson compile -C build
32 check() {
33   meson test -C build --print-errorlogs
36 package() {
37   depends+=(libg{lib,object,io}-2.0.so libcanberra.so)
38   provides+=(libgsound.so)
40   meson install -C build --destdir "$pkgdir"