archrelease: copy trunk to extra-x86_64
[arch-packages.git] / libebml / repos / extra-x86_64 / PKGBUILD
blob3d7c86f21f9e6f15871229130b8e7e76527f8e8b
1 # Maintainer: Giovanni Scafora <giovanni@archlinux.org>
2 # Maintainer: Maxime Gauduin <alucryd@archlinux.org>
3 # Contributor: 03/08/04 <lefungus@altern.org>
5 pkgname=libebml
6 pkgver=1.4.2
7 pkgrel=2
8 pkgdesc='Extensible Binary Meta Language library'
9 arch=(x86_64)
10 url=https://github.com/Matroska-Org/libebml
11 license=(LGPL2.1)
12 depends=(gcc-libs)
13 makedepends=(
14   cmake
15   git
16   ninja
18 provides=(libebml.so)
19 _tag=6c59e5e1ce0087e4465f6d3f479449d3f6bcb167
20 source=(
21   git+https://github.com/Matroska-Org/libebml.git#tag=${_tag}
22   libebml-limits.patch
24 b2sums=('SKIP'
25         '62aaeb70d83c91af422b70a3e21ef7e538201c01e1b088a7e05d0bde02078fa6ed723ea3d0dc01da0bfbac4012e2b0c683de7abb26eb5d38553e7905f0ff8bfd')
27 prepare() {
28   cd libebml
29   patch -Np1 -i ../libebml-limits.patch
32 pkgver() {
33   cd libebml
34   git describe --tags | sed 's/^release-//'
37 build() {
38   cmake -S libebml -B build -G Ninja \
39     -DCMAKE_INSTALL_PREFIX=/usr \
40     -DCMAKE_INSTALL_LIBDIR=/usr/lib \
41     -DBUILD_SHARED_LIBS=ON
42   cmake --build build
45 package() {
46   DESTDIR="${pkgdir}" cmake --install build
49 # vim: ts=2 sw=2 et: