2 # Contributor: Ronald van Haren <ronald.archlinux.org>
3 # Contributor: boromil@gmail.com
5 pkgname=ffmpegthumbnailer
8 pkgdesc="Lightweight video thumbnailer that can be used by file managers"
9 url="https://github.com/dirkvdb/ffmpegthumbnailer"
12 depends=('ffmpeg' 'libjpeg' 'libpng')
14 optdepends=('gvfs: support for gio uris')
15 source=(https://github.com/dirkvdb/$pkgname/archive/$pkgver/$pkgname-$pkgver.tar.gz
16 ffmpegthumbnailer-ffmpeg5.patch::https://patch-diff.githubusercontent.com/raw/dirkvdb/ffmpegthumbnailer/pull/198.patch
17 https://github.com/dirkvdb/ffmpegthumbnailer/commit/efb5b618.patch)
18 sha256sums=('8c4c42ab68144a9e2349710d42c0248407a87e7dc0ba4366891905322b331f92'
19 '300d3208fca6de6f7a90fbabbb8e58b9cf0cc4a4c9b1d2df0cd53ece1736646a'
20 'c266d1c7cab2fa26dfee2410ea6864ab81a57e8784eda6574cd8237750b9e0e1')
23 patch -d $pkgname-$pkgver -p1 < ffmpegthumbnailer-ffmpeg5.patch # Fix build with FFmpeg 5
24 patch -d $pkgname-$pkgver -p1 < efb5b618.patch # Fix build with FFmpeg 5
28 cmake -B build -S $pkgname-$pkgver \
29 -DCMAKE_INSTALL_PREFIX=/usr \
31 -DENABLE_THUMBNAILER=ON
36 DESTDIR="${pkgdir}" cmake --install build