1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
2 # Maintainer: Felix Yan <felixonmars@archlinux.org>
9 url='https://www.qt.io'
10 license=(GPL3 LGPL3 FDL custom)
11 pkgdesc='Provides support for web applications using the Chromium browser project'
12 depends=(qt6-webchannel qt6-positioning libxcomposite libxrandr libxkbfile
13 snappy nss libxslt minizip ffmpeg re2 libvpx libxtst ttf-font) # pciutils
14 makedepends=(cmake ninja python-html5lib gperf jsoncpp qt6-tools pipewire nodejs qt6-websockets libepoxy git)
15 optdepends=('pipewire: WebRTC desktop sharing under Wayland')
17 _pkgfn=${pkgname/6-/}-everywhere-src-$_qtver
18 source=(https://download.qt.io/official_releases/qt/${pkgver%.*}/$_qtver/submodules/$_pkgfn.tar.xz)
19 sha256sums=('2a10da34a71b307e9ff11ec086455dd20b83d5b0ee6bda499c4ba9221e306f07')
22 cmake -B build -S $_pkgfn -G Ninja \
23 -DCMAKE_MESSAGE_LOG_LEVEL=STATUS \
24 -DCMAKE_TOOLCHAIN_FILE=/usr/lib/cmake/Qt6/qt.toolchain.cmake \
25 -DQT_FEATURE_webengine_system_ffmpeg=ON \
26 -DQT_FEATURE_webengine_system_icu=ON \
27 -DQT_FEATURE_webengine_system_libevent=ON \
28 -DQT_FEATURE_webengine_proprietary_codecs=ON \
29 -DQT_FEATURE_webengine_kerberos=ON \
30 -DQT_FEATURE_webengine_webrtc_pipewire=ON
35 DESTDIR="$pkgdir" cmake --install build
37 install -Dm644 "$srcdir"/${_pkgfn}/src/3rdparty/chromium/LICENSE "$pkgdir"/usr/share/licenses/${pkgname}/LICENSE.chromium