7.3.0-1
[arch-packages.git] / qt6-webengine / trunk / PKGBUILD
blob496a9fcee7e18e1cf456bc0c0ef41fe9a9145917
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
2 # Maintainer: Felix Yan <felixonmars@archlinux.org>
4 pkgname=qt6-webengine
5 _qtver=6.5.0
6 pkgver=${_qtver/-/}
7 pkgrel=2
8 arch=(x86_64)
9 url='https://www.qt.io'
10 license=(GPL3 LGPL3 FDL custom)
11 pkgdesc='Provides support for web applications using the Chromium browser project'
12 depends=(qt6-webchannel qt6-positioning libxcomposite libxrandr libxkbfile 
13          snappy nss libxslt minizip ffmpeg re2 libvpx libxtst ttf-font) # pciutils
14 makedepends=(cmake ninja python-html5lib gperf jsoncpp qt6-tools pipewire nodejs qt6-websockets libepoxy git)
15 optdepends=('pipewire: WebRTC desktop sharing under Wayland')
16 groups=(qt6)
17 _pkgfn=${pkgname/6-/}-everywhere-src-$_qtver
18 source=(https://download.qt.io/official_releases/qt/${pkgver%.*}/$_qtver/submodules/$_pkgfn.tar.xz)
19 sha256sums=('2a10da34a71b307e9ff11ec086455dd20b83d5b0ee6bda499c4ba9221e306f07')
21 build() {
22   cmake -B build -S $_pkgfn -G Ninja \
23     -DCMAKE_MESSAGE_LOG_LEVEL=STATUS \
24     -DCMAKE_TOOLCHAIN_FILE=/usr/lib/cmake/Qt6/qt.toolchain.cmake \
25     -DQT_FEATURE_webengine_system_ffmpeg=ON \
26     -DQT_FEATURE_webengine_system_icu=ON \
27     -DQT_FEATURE_webengine_system_libevent=ON \
28     -DQT_FEATURE_webengine_proprietary_codecs=ON \
29     -DQT_FEATURE_webengine_kerberos=ON \
30     -DQT_FEATURE_webengine_webrtc_pipewire=ON
31   cmake --build build
34 package() {
35   DESTDIR="$pkgdir" cmake --install build
37   install -Dm644 "$srcdir"/${_pkgfn}/src/3rdparty/chromium/LICENSE "$pkgdir"/usr/share/licenses/${pkgname}/LICENSE.chromium