7.3.0-1
[arch-packages.git] / xcb-util-renderutil / trunk / PKGBUILD
blob66ff035884c75d16cd3b0a6db9359dd5b67b2eb1
1 # Maintainer: Andreas Radke <andyrtr@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
4 pkgname=xcb-util-renderutil
5 pkgver=0.3.10
6 pkgrel=1
7 pkgdesc="Utility libraries for XC Binding - Convenience functions for the Render extension"
8 arch=('x86_64')
9 url="https://xcb.freedesktop.org"
10 license=('custom')
11 depends=('libxcb>=1.7')
12 makedepends=('xorg-util-macros' 'xorgproto')
13 source=(https://xorg.freedesktop.org/archive/individual/lib/${pkgname}-${pkgver}.tar.xz{,.sig})
14 sha512sums=('9cfa9201be2df7c0b832e1e1fe506e7c7a1e0f2b1b1d4a4b58620eadc241190a36478fa3ea27c32047fa79bf199f17dcd0b106853dbf5eda8cd584f3fc2b0c15'
15             'SKIP')
16 validpgpkeys=('4A193C06D35E7C670FA4EF0BA2FB9E081F2D130E') # Alan Coopersmith <alan.coopersmith@oracle.com>
18 build() {
19   cd ${pkgname}-${pkgver}
20   ./configure --prefix=/usr --disable-static
21   make
24 check() {
25   cd ${pkgname}-${pkgver}
26   make check
29 package() { 
30   cd ${pkgname}-${pkgver}
31   make DESTDIR="${pkgdir}" install
32   install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/LICENSE"