db-move: moved d-spy from [testing] to [extra] (x86_64)
[arch-packages.git] / ki18n / trunk / PKGBUILD
blob7e46773321ac00b269cab598047c3196fbf5e9d3
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Maintainer: Antonio Rojas <arojas@archlinux.org>
3 # Contributor: Andrea Scarpino <andrea@archlinux.org>
5 pkgname=ki18n
6 pkgver=5.105.0
7 pkgrel=1
8 pkgdesc='Advanced internationalization framework'
9 arch=(x86_64)
10 url='https://community.kde.org/Frameworks'
11 license=(LGPL)
12 depends=(qt5-declarative iso-codes)
13 makedepends=(extra-cmake-modules clang doxygen qt5-tools qt5-doc python)
14 optdepends=('python: to compile .ts files')
15 groups=(kf5)
16 source=(https://download.kde.org/stable/frameworks/${pkgver%.*}/$pkgname-$pkgver.tar.xz{,.sig})
17 sha256sums=('ba26cd1fc188ab305293f8f1276ab7871f57f4ab1309bb8d2adf42fb20958f3a'
18             'SKIP')
19 validpgpkeys=(53E6B47B45CEA3E0D5B7457758D0EE648A48B3BB) # David Faure <faure@kde.org>
21 build() {
22   cmake -B build -S $pkgname-$pkgver \
23     -DBUILD_TESTING=OFF \
24     -DBUILD_QCH=ON
25   cmake --build build
28 package() {
29   DESTDIR="$pkgdir" cmake --install build