archrelease: copy trunk to staging-x86_64
[arch-packages.git] / python-markupsafe / repos / extra-x86_64 / PKGBUILD
blobbaa125d3628194710e8241c20ca840fdd67e7ef1
1 # Maintainer : Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Ionut Biru <ibiru@archlinux.org>
3 # Contributor: Alex Anthony <alex.anthony28991@gmail.com>
5 pkgname=python-markupsafe
6 pkgver=2.1.2
7 _commit=c0254f0cfe51720ecc9e72e8896022af29af5b44
8 pkgrel=3
9 pkgdesc="Implements a XML/HTML/XHTML Markup safe string for Python"
10 arch=('x86_64')
11 url="https://pypi.python.org/pypi/MarkupSafe"
12 license=('BSD')
13 depends=('python')
14 makedepends=('git' 'python-setuptools')
15 checkdepends=('python-pytest')
16 source=("git+https://github.com/pallets/markupsafe.git#commit=$_commit")
17 sha512sums=('SKIP')
19 build() {
20   cd markupsafe
21   python setup.py build
24 check() {
25   cd markupsafe
26   PYTHONPATH=src pytest
29 package() {
30   cd markupsafe
31   python setup.py install --root="$pkgdir" --optimize=1
32   install -Dm644 LICENSE.rst -t "$pkgdir"/usr/share/licenses/$pkgname/