archrelease: copy trunk to staging-x86_64
[arch-packages.git] / xorg-xmodmap / trunk / PKGBUILD
blob74b87b8feb2162a08e2d6ef204348d30ba8fae3a
1 # Maintainer: Andreas Radke <andyrtr@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
4 pkgname=xorg-xmodmap
5 pkgver=1.0.11
6 pkgrel=1
7 pkgdesc="Utility for modifying keymaps and button mappings"
8 arch=('x86_64')
9 url="https://xorg.freedesktop.org/"
10 license=('custom')
11 depends=('libx11')
12 makedepends=('xorg-util-macros')
13 groups=('xorg-apps' 'xorg')
14 source=(https://xorg.freedesktop.org/archive/individual/app/xmodmap-${pkgver}.tar.xz{,.sig})
15 sha512sums=('a78f916f048d2017f079733becc99232c087c360ece61ec6c4fa4b5b130b96a1b10c4ce1b64a15bdcab7ea05de3c7f16035503d5be6f8ce1a7612ce71d558510'
16             'SKIP')
17 validpgpkeys=('4A193C06D35E7C670FA4EF0BA2FB9E081F2D130E') # Alan Coopersmith <alan.coopersmith@oracle.com>
19 build() {
20   cd xmodmap-${pkgver}
21   ./configure --prefix=/usr
22   make
25 package() {
26   cd xmodmap-${pkgver}
27   make DESTDIR="${pkgdir}" install
28   install -Dm644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"