db-move: moved django from [testing] to [extra] (any)
[arch-packages.git] / editorconfig-core-c / trunk / PKGBUILD
blobb3e1703f17b7103b470d6bfa61255f82539faa1a
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
2 # Contributor: Matt Harrison <matt@harrison.us.com>
3 # Contributor: Erik van der Kolk <developer at smerik dot nl>
4 # Contributor: Hong Xu
6 pkgname=editorconfig-core-c
7 pkgver=0.12.5
8 pkgrel=1
9 pkgdesc='EditorConfig core code written in C (for use by plugins supporting EditorConfig parsing)'
10 arch=(x86_64)
11 url='https://github.com/editorconfig/editorconfig-core-c'
12 license=(BSD)
13 depends=(pcre2)
14 makedepends=(cmake doxygen)
15 source=(https://github.com/editorconfig/$pkgname/archive/v$pkgver/$pkgname-$pkgver.tar.gz)
16 sha256sums=('b2b212e52e7ea6245e21eaf818ee458ba1c16117811a41e4998f3f2a1df298d2')
18 build() {
19   cmake -B build -S $pkgname-$pkgver \
20       -DCMAKE_INSTALL_PREFIX=/usr \
21       -DCMAKE_C_FLAGS="$CFLAGS -ffat-lto-objects"
22   cmake --build build
25 package() {
26   DESTDIR="$pkgdir" cmake --install build
28   install -Dm644 $pkgname-$pkgver/LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname