1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
6 pkgdesc="A library for manipulating storage volume encryption keys and storing them separately from volumes to handle forgotten passphrases"
8 url="https://pagure.io/volume_key"
10 depends=('cryptsetup' 'nss' 'gpgme')
11 makedepends=('python' 'swig')
12 optdepends=('python: for python bindings')
13 source=("https://releases.pagure.org/volume_key/volume_key-$pkgver.tar.xz")
14 sha512sums=('d056154c9b9d23e4eb661946dd59ed97e116903a3afcff9d9e29258408082f33dcbb69958724143f6bf191a3da488a03b6c02af287790990ed6459e29d66553c')
19 find . -name ".pyc" -delete
24 export CFLAGS+=" $(python3-config --includes)"
25 ./configure --prefix=/usr
31 make DESTDIR="$pkgdir" install
32 sed -i '/#include <config.h>/d' "$pkgdir"/usr/include/volume_key/libvolume_key.h