db-move: moved gnome-weather from [staging] to [testing] (any)
[arch-packages.git] / gst-plugins-good / trunk / PKGBUILD
blobe834bf7ff8a5385fdcd4a420b6a4438c7ec73dfe
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
4 pkgbase=gst-plugins-good
5 pkgname=(gst-plugins-good gst-plugin-gtk gst-plugin-qmlgl)
6 pkgver=1.18.5
7 pkgrel=2
8 pkgdesc="Multimedia graph framework - good plugins"
9 url="https://gstreamer.freedesktop.org/"
10 arch=(x86_64)
11 license=(LGPL)
12 depends=(libpulse libsoup gst-plugins-base-libs wavpack aalib taglib libdv libshout libvpx
13          gdk-pixbuf2 libcaca libavc1394 libiec61883 libxdamage v4l-utils cairo libgudev speex flac
14          libraw1394 lame mpg123 twolame)
15 makedepends=(python git meson jack2 gtk3 qt5-{tools,declarative,x11extras,wayland} nasm)
16 checkdepends=(gst-plugins-base xorg-server-xvfb)
17 options=(!emptydirs)
18 _commit=56dec037a80266add6853e4b06e2dc379de757d1  # tags/1.18.5^0
19 source=("git+https://gitlab.freedesktop.org/gstreamer/gst-plugins-good.git#commit=$_commit")
20 sha256sums=('SKIP')
22 pkgver() {
23   cd $pkgname
24   git describe --tags | sed 's/-/+/g'
27 prepare() {
28   cd $pkgname
31 build() {
32   arch-meson $pkgname build \
33     -D doc=disabled \
34     -D rpicamsrc=disabled \
35     -D gobject-cast-checks=disabled \
36     -D package-name="GStreamer Good Plugins (Arch Linux)" \
37     -D package-origin="https://www.archlinux.org/"
38   meson compile -C build
41 check() (
42   mkdir -p -m 700 "${XDG_RUNTIME_DIR:=$PWD/runtime-dir}"
43   export XDG_RUNTIME_DIR
45   xvfb-run -s '-nolisten local' \
46     meson test -C build --print-errorlogs
49 package_gst-plugins-good() {
50   depends+=(libjack.so)
52   meson install -C build --destdir "$pkgdir"
54   for _x in gtk qmlgl; do
55     mkdir -p "$_x/lib/gstreamer-1.0"
56     _f="lib/gstreamer-1.0/libgst${_x}.so"
57     mv "$pkgdir/usr/$_f" "$_x/$_f"
58   done
61 package_gst-plugin-gtk() {
62   pkgdesc="${pkgdesc%-*}- gtk plugin"
63   depends=(gst-plugins-base-libs gtk3)
65   mv gtk "$pkgdir/usr"
68 package_gst-plugin-qmlgl() {
69   pkgdesc="${pkgdesc%-*}- qmlgl plugin"
70   depends=(gst-plugins-base-libs qt5-{declarative,x11extras,wayland})
72   mv qmlgl "$pkgdir/usr"