db-move: moved gnome-weather from [staging] to [testing] (any)
[arch-packages.git] / liblangtag / repos / extra-x86_64 / PKGBUILD
blobf28ce9e6c2f174203971ac6bc5c287a8dddaa7c0
1 # Maintainer: AndyRTR <andyrtr@archlinux.org>
3 pkgname=liblangtag
4 pkgver=0.6.4
5 pkgrel=1
6 pkgdesc="interface library to access/deal with tags for identifying languages"
7 arch=('x86_64')
8 url="https://bitbucket.org/tagoh/liblangtag/wiki/Home"
9 license=('LGPL3' 'MPL') # actually MPL2.0
10 depends=('libxml2' 'glib2')
11 makedepends=('gobject-introspection')
12 optdepends=('gobject-introspection-runtime: use with liblangtag-gobject')
13 source=(https://bitbucket.org/tagoh/liblangtag/downloads/$pkgname-$pkgver.tar.bz2)
14 sha256sums=('5701062c17d3e73ddaa49956cbfa5d47d2f8221988dec561c0af2118c1c8a564')
16 build() {
17   cd "$pkgname-$pkgver"
18   ./configure --prefix=/usr
19   sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
20   make
23 check() {
24   cd "$pkgname-$pkgver"
25   make -k check
28 package() {
29   cd "$pkgname-$pkgver"
30   make DESTDIR="$pkgdir/" install