db-move: moved gnome-weather from [staging] to [testing] (any)
[arch-packages.git] / perl-net-ip / trunk / PKGBUILD
blobf0cbf3b47e4ebc24c9e3f2cefec8314e36105475
1 # Maintainer: Felix Yan <felixonmars@gmail.com>
2 # Contributor: Kevin Piche <kevin@archlinux.org>
4 pkgname=perl-net-ip
5 _realname=Net-IP
6 pkgver=1.26
7 pkgrel=11
8 pkgdesc="Perl Module:  Easy manipulation of IPv4 and IPv6 addresses"
9 arch=('any')
10 license=('PerlArtistic')
11 url="https://search.cpan.org/dist/Net-IP/"
12 depends=('perl')
13 options=(!emptydirs)
14 source=("https://www.cpan.org/authors/id/M/MA/MANU/Net-IP-$pkgver.tar.gz")
15 sha256sums=('040f16f3066647d761b724a3b70754d28cbd1e6fe5ea01c63ed1cd857117d639')
17 build() {
18   cd Net-IP-$pkgver
19   PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
20   make
23 check() {
24   cd Net-IP-$pkgver
25   make test
28 package() {
29   cd Net-IP-$pkgver
30   make install DESTDIR="$pkgdir"