db-move: moved gnome-weather from [staging] to [testing] (any)
[arch-packages.git] / pkcs11-helper / repos / extra-x86_64 / PKGBUILD
blob83581d105118c55cb2f788e41a42159c86806d32
1 # Maintainer:
2 # Contributor: Stanislaw Datskevich <me a nek0 net>
3 # Contributor: Gregor Robinson <gregor@fiatflux.co.uk>
4 # Contributor: Martin Perner <martin dot perner at gmail dot com>
6 pkgname=pkcs11-helper
7 pkgver=1.29.0
8 pkgrel=2
9 pkgdesc='A library that simplifies the interaction with PKCS11 providers for end-user applications using a simple API and optional OpenSSL engine'
10 arch=('x86_64')
11 url='https://github.com/OpenSC/pkcs11-helper'
12 license=('GPL' 'BSD')
13 depends=('gnutls' 'nss' 'openssl')
14 provides=('libpkcs11-helper.so')
15 options=('debug')
16 source=("https://github.com/OpenSC/${pkgname}/releases/download/${pkgname}-${pkgver}/${pkgname}-${pkgver}.tar.bz2")
17 sha256sums=('996846a3c8395e03d8c0515111dc84d82e6e3648d44ba28cb2dbbbca2d4db7d6')
19 build() {
20   cd pkcs11-helper-$pkgver
22   libtoolize
23   aclocal
24   autoheader
25   automake --add-missing
26   autoreconf -v
27   ./configure --prefix=/usr
28   make
31 package() {
32   cd pkcs11-helper-$pkgver
34   make DESTDIR="$pkgdir" install
35   mkdir -p "$pkgdir"/usr/share/licenses/$pkgname/
36   install -D -m0644 COPYING* "$pkgdir"/usr/share/licenses/$pkgname/