1 # Maintainer: Maxime Gauduin <alucryd@archlinux.org>
2 # Contributor: Guillaume ALAUX <guillaume@archlinux.org>
4 pkgbase=java-commons-daemon
12 url=https://commons.apache.org/proper/commons-daemon/
14 _tag=466cc9a2442412dbb25dc5dad803982a7f864264
15 source=(git+https://github.com/apache/commons-daemon.git#tag=${_tag})
27 cd commons-daemon/src/native/unix
33 git describe --tags | sed 's/commons-daemon-//'
41 --with-java=/usr/lib/jvm/default
43 db2x_docbook2man man/jsvc.1.xml
46 package_java-commons-daemon() {
47 pkgdesc='Alternative invocation mechanism for unix-daemon-like java code'
48 depends=(java-runtime)
51 install -Dm 644 target/commons-daemon-${pkgver}.jar -t "${pkgdir}"/usr/share/java/
52 ln -s commons-daemon-${pkgver}.jar "${pkgdir}"/usr/share/java/commons-daemon.jar
56 pkgdesc='Apache application for making Java applications run on UNIX more easily'
62 cd commons-daemon/src/native/unix
63 install -Dm 755 jsvc -t "${pkgdir}"/usr/bin/
64 install -Dm 644 JSVC.1 -t "${pkgdir}"/usr/share/man/man1/