OCaml 4.14.0 rebuild
[arch-packages.git] / numactl / repos / extra-x86_64 / PKGBUILD
blob650da75bb80362a947991aa0bdaa6b7451c89033
1 # Maintainer: David Runge <dvzrv@archlinux.org>
2 # Contributor: Dan McGee <dan@archlinux.org>
3 # Contributor: Florian Zeitz <florob at babelmonkeys dot de>
5 pkgname=numactl
6 pkgver=2.0.14
7 pkgrel=3
8 pkgdesc="Simple NUMA policy support"
9 arch=(x86_64)
10 url="https://github.com/numactl/numactl"
11 license=(LGPL2.1 GPL2)
12 depends=(glibc)
13 provides=(libnuma.so)
14 options=(debug)
15 source=(https://github.com/numactl/numactl/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz)
16 sha512sums=('28b95985d6b2f26c5f6f15fe235224c998c86f534adf5fdaa355a292cf2fd65515c91ba2a76c899d552d439b18ea1209a1712bd6755f8ee3a442f3935993b2e6')
17 b2sums=('5f2abe25061ac29ecad8a6b24fe800d72c3538d9a155358f4b329ed1140053c7dbd93f01891904f76db94ed01113a34b4ebcbbf40e4060caf747958785ac9590')
19 prepare(){
20   cd $pkgname-$pkgver
21   autoreconf -fiv
24 build() {
25   cd $pkgname-$pkgver
26   ./configure --prefix=/usr
27   make
30 check() {
31   make -k test -C $pkgname-$pkgver || echo "Tests known to fail depending on system load."
34 package() {
35   make DESTDIR="$pkgdir" install -C $pkgname-$pkgver
36   install -vDm 644 $pkgname-$pkgver/README.md -t "$pkgdir/usr/share/doc/$pkgname/"
37   # move_pages(2) is provided by man-pages and is more up-to-date there anyway
38   rm -rf "$pkgdir/usr/share/man/man2"