1 # Maintainer: David Runge <dvzrv@archlinux.org>
2 # Contributor: Dan McGee <dan@archlinux.org>
3 # Contributor: Florian Zeitz <florob at babelmonkeys dot de>
8 pkgdesc="Simple NUMA policy support"
10 url="https://github.com/numactl/numactl"
11 license=(LGPL2.1 GPL2)
15 source=(https://github.com/numactl/numactl/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz)
16 sha512sums=('28b95985d6b2f26c5f6f15fe235224c998c86f534adf5fdaa355a292cf2fd65515c91ba2a76c899d552d439b18ea1209a1712bd6755f8ee3a442f3935993b2e6')
17 b2sums=('5f2abe25061ac29ecad8a6b24fe800d72c3538d9a155358f4b329ed1140053c7dbd93f01891904f76db94ed01113a34b4ebcbbf40e4060caf747958785ac9590')
26 ./configure --prefix=/usr
31 make -k test -C $pkgname-$pkgver || echo "Tests known to fail depending on system load."
35 make DESTDIR="$pkgdir" install -C $pkgname-$pkgver
36 install -vDm 644 $pkgname-$pkgver/README.md -t "$pkgdir/usr/share/doc/$pkgname/"
37 # move_pages(2) is provided by man-pages and is more up-to-date there anyway
38 rm -rf "$pkgdir/usr/share/man/man2"