db-move: moved polari from [testing] to [extra] (x86_64)
[arch-packages.git] / flatpak-builder / repos / extra-x86_64 / PKGBUILD
blob73421de5129824fd7170ba7dcb4dcf093f90af2f
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
3 pkgname=flatpak-builder
4 pkgver=1.2.3
5 pkgrel=1
6 pkgdesc="Tool to build flatpaks from source"
7 url="https://flatpak.org"
8 arch=(x86_64)
9 license=(LGPL)
10 depends=(flatpak binutils elfutils unzip tar git bzr patch rpmextract cpio
11          appstream-glib fuse3)
12 makedepends=(gobject-introspection git docbook-xsl xmlto)
13 checkdepends=(valgrind)
14 replaces=('flatpak<0.9.10')
15 options=(debug)
16 _commit=d7dbc51267e83242a9fe0d5a7b5304db0ac72f4f  # tags/1.2.3
17 source=(
18   "git+https://github.com/flatpak/flatpak-builder#commit=$_commit"
19   "git+https://gitlab.gnome.org/GNOME/libglnx.git"
20   "git+https://sourceware.org/git/debugedit.git"
21   fusermount3.diff
23 sha256sums=('SKIP'
24             'SKIP'
25             'SKIP'
26             '984ea70ac2c5794c758523aba9c1f643dc21fb01db4ed962987935a454d521a7')
28 pkgver() {
29   cd $pkgname
30   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
33 prepare() {
34   cd $pkgname
36   # https://bugs.archlinux.org/task/75649
37   git apply -3 ../fusermount3.diff
39   git submodule init
40   git submodule set-url libglnx "$srcdir/libglnx"
41   git submodule set-url debugedit "$srcdir/debugedit"
42   git -c protocol.file.allow=always submodule update
44   NOCONFIGURE=1 ./autogen.sh
47 build() {
48   cd $pkgname
50   ./configure \
51     --prefix=/usr \
52     --sysconfdir=/etc \
53     --localstatedir=/var \
54     --sbindir=/usr/bin \
55     --libexecdir=/usr/lib \
56     --disable-static
58   sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
60   make
63 check() {
64   cd $pkgname
65   make -k check
68 package() {
69   cd $pkgname
70   make DESTDIR="$pkgdir" install
73 # vim:set sw=2 sts=-1 et: