1 # Maintainer: Andreas Radke <andyrtr@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
7 pkgdesc="A library which provides a secure layer over a reliable transport layer"
9 license=('GPL3' 'LGPL2.1')
10 url="https://www.gnutls.org/"
12 depends=('gcc-libs' 'libtasn1' 'readline' 'zlib' 'nettle' 'p11-kit' 'libidn2'
13 'zstd' 'libidn2.so' 'libunistring' 'brotli')
14 makedepends=('tpm2-tss')
15 checkdepends=('net-tools' 'tpm2-tools')
16 optdepends=('tpm2-tss: support for TPM2 wrapped keys')
17 source=(https://www.gnupg.org/ftp/gcrypt/gnutls/v3.8/${pkgname}-${pkgver}.tar.xz{,.sig})
18 sha256sums=('0ea0d11a1660a1e63f960f157b197abe6d0c8cb3255be24e1fb3815930b9bdc5'
20 validpgpkeys=('462225C3B46F34879FC8496CD605848ED7E69871') # "Daiki Ueno <ueno@unixuser.org>"
21 #validpgpkeys=('5D46CB0F763405A7053556F47A75A648B3F9220C') # "Zoltan Fridrich <zfridric@redhat.com>"
24 cd ${pkgname}-${pkgver}
25 ./configure --prefix=/usr \
31 --enable-openssl-compatibility \
32 --with-default-trust-store-pkcs11="pkcs11:"
33 # --enable-ktls \ # breaks testsuite
34 sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
39 cd ${pkgname}-${pkgver}
40 # disable parallel tests:
47 cd ${pkgname}-${pkgver}
48 make DESTDIR="${pkgdir}" install
50 # lots of .png files are put into infodir and are gzipped by makepkg! this needs to be fixed by using !zipman
51 # gzip -9 all files in infodir and manpages manually
52 find "$pkgdir/usr/share/info" -name '*.info*' -exec gzip -n -9 {} \;
53 find "$pkgdir/usr/share/man" -exec gzip -n -9 {} \;