db-move: moved polari from [testing] to [extra] (x86_64)
[arch-packages.git] / imath / trunk / PKGBUILD
blobb8561e4099d32f1c685b40f7101764345d14240d
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
3 pkgname=imath
4 pkgver=3.1.7
5 pkgrel=2
6 pkgdesc='A C++ and python library of 2D and 3D vector, matrix, and math operations for computer graphics'
7 url='https://www.openexr.com/'
8 arch=(x86_64)
9 license=(BSD)
10 depends=(gcc-libs)
11 optdepends=('python: python bindings' 'boost-libs: python bindings')
12 makedepends=(cmake python boost)
13 source=(https://github.com/AcademySoftwareFoundation/Imath/archive/v$pkgver/$pkgname-$pkgver.tar.gz)
14 sha256sums=('bff1fa140f4af0e7f02c6cb78d41b9a7d5508e6bcdfda3a583e35460eb6d4b47')
16 build() {
17   cmake -B build -S Imath-$pkgver \
18     -DCMAKE_INSTALL_PREFIX=/usr \
19     -DPYTHON=ON
20   cmake --build build
23 package() {
24   DESTDIR="$pkgdir" cmake --install build
25   install -Dm644 Imath-$pkgver/LICENSE.md -t "$pkgdir"/usr/share/licenses/$pkgname