1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
6 pkgdesc='A C++ and python library of 2D and 3D vector, matrix, and math operations for computer graphics'
7 url='https://www.openexr.com/'
11 optdepends=('python: python bindings' 'boost-libs: python bindings')
12 makedepends=(cmake python boost)
13 source=(https://github.com/AcademySoftwareFoundation/Imath/archive/v$pkgver/$pkgname-$pkgver.tar.gz)
14 sha256sums=('bff1fa140f4af0e7f02c6cb78d41b9a7d5508e6bcdfda3a583e35460eb6d4b47')
17 cmake -B build -S Imath-$pkgver \
18 -DCMAKE_INSTALL_PREFIX=/usr \
24 DESTDIR="$pkgdir" cmake --install build
25 install -Dm644 Imath-$pkgver/LICENSE.md -t "$pkgdir"/usr/share/licenses/$pkgname