db-move: moved polari from [testing] to [extra] (x86_64)
[arch-packages.git] / kwayland-integration / repos / extra-x86_64 / PKGBUILD
blob18b4d27d103eda9e7331d5a19de3dae8e748877c
1 # Maintainer:Antonio Rojas <arojas@archlinux.org>
3 pkgname=kwayland-integration
4 pkgver=5.27.4
5 pkgrel=1
6 pkgdesc='Provides integration plugins for various KDE frameworks for the wayland windowing system'
7 arch=(x86_64)
8 url='https://kde.org/plasma-desktop/'
9 license=(LGPL)
10 depends=(kwindowsystem kwayland)
11 makedepends=(extra-cmake-modules wayland-protocols kidletime)
12 groups=(plasma)
13 source=(https://download.kde.org/stable/plasma/$pkgver/$pkgname-$pkgver.tar.xz{,.sig})
14 sha256sums=('f74a856a93e0bd91ad7c34905603c2ed74df1dc85e687354d9d588274026fe08'
15             'SKIP')
16 validpgpkeys=('E0A3EB202F8E57528E13E72FD7574483BB57B18D'  # Jonathan Esk-Riddell <jr@jriddell.org>
17               '0AAC775BB6437A8D9AF7A3ACFE0784117FBCE11D'  # Bhushan Shah <bshah@kde.org>
18               'D07BD8662C56CB291B316EB2F5675605C74E02CF'  # David Edmundson <davidedmundson@kde.org>
19               '1FA881591C26B276D7A5518EEAAF29B42A678C20') # Marco Martin <notmart@gmail.com>
21 build() {
22   cmake -B build -S $pkgname-$pkgver \
23     -DBUILD_TESTING=OFF
24   cmake --build build
27 package() {
28   DESTDIR="$pkgdir" cmake --install build