db-move: moved polari from [testing] to [extra] (x86_64)
[arch-packages.git] / libusbmuxd / trunk / PKGBUILD
blob7fa5e4ff397f3298a0c27dee02a2c774197e6a05
1 # Maintainer: Ionut Biru <ibiru@archlinux.org>
2 # Maintainer: Jan de Groot <jgc@archlinux.org>
3 # Contributor: Gabriel Martinez < reitaka at gmail dot com >
5 pkgname=libusbmuxd
6 pkgver=2.0.2
7 pkgrel=1
8 pkgdesc="USB Multiplex Daemon"
9 url="https://marcansoft.com/blog/iphonelinux/usbmuxd/"
10 arch=('x86_64')
11 license=('LGPL2.1' 'GPL2')
12 depends=('libusb' 'libplist')
13 makedepends=(git)
14 conflicts=('usbmuxd<1.0.9')
15 _commit=ce98c346b7c1dc2a21faea4fd3f32c88e27ca2af
16 source=("git+https://github.com/libimobiledevice/libusbmuxd#commit=$_commit")
17 sha256sums=('SKIP')
19 pkgver() {
20   cd $pkgname
21   git describe --tags | sed 's/-/+/g'
24 check() {
25   cd $pkgname
26   make check
29 prepare() {
30   cd $pkgname
31   NOCONFIGURE=1 ./autogen.sh
34 build() {
35   cd $pkgname
36   ./configure --prefix=/usr
37   make
40 package() {
41   cd $pkgname
42   make DESTDIR="${pkgdir}" install