1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
8 pkgdesc="Self-service finite-state machines for the programmer on the go."
9 url="https://github.com/glyph/automat"
10 depends=('python-attrs' 'python-six')
11 makedepends=('python-setuptools-scm' 'python-wheel')
12 checkdepends=('python-pytest-benchmark' 'python-twisted' 'python-graphviz')
13 optdepends=('python-graphviz: for automat-visualize'
14 'python-twisted: for automat-visualize')
15 source=("https://github.com/glyph/automat/archive/v$pkgver/$pkgname-$pkgver.tar.gz")
16 sha512sums=('16caea66a8621b7d50e68e94007085218ec40ae0f57599d5076ed1915d4a2ebabd2da66659ba70acb9c6d30bc354bcd6126f913af0c0a005db305ca0c203481d')
18 export SETUPTOOLS_SCM_PRETEND_VERSION=$pkgver
32 python setup.py install --root="$pkgdir" --optimize=1
33 install -Dm644 LICENSE -t "$pkgdir"/usr/share/licenses/python-automat/