1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
2 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 # Contributor: Andrea Scarpino <andrea@archlinux.org>
10 url='https://www.qt.io'
11 license=(GPL3 LGPL3 FDL custom)
12 pkgdesc='A cross-platform application and UI framework (Development Tools, QtHelp)'
14 makedepends=(cmake ninja qt6-declarative clang llvm litehtml)
15 optdepends=('qt6-declarative: for qdoc' 'clang: for qdoc and lupdate' 'litehtml: for assistant')
17 _pkgfn=${pkgname/6-/}-everywhere-src-$_qtver
18 source=(https://download.qt.io/official_releases/qt/${pkgver%.*}/$_qtver/submodules/$_pkgfn.tar.xz)
19 sha256sums=('49c33d96b0a44988be954269b8ce3d1a495b439726e03a6be7c0d50a686369c4')
22 # Fix build with system litehtml
23 sed -e '/qt_internal_set_exceptions_flags/d' -e '/qt_disable_warnings/d' -i $_pkgfn/src/assistant/CMakeLists.txt
27 cmake -B build -S $_pkgfn -G Ninja \
28 -DINSTALL_PUBLICBINDIR=usr/bin \
29 -DCMAKE_MESSAGE_LOG_LEVEL=STATUS
34 DESTDIR="$pkgdir" cmake --install build
36 # Install symlinks for user-facing tools
41 done < "$srcdir"/build/user_facing_tool_links.txt
43 install -d "$pkgdir"/usr/share/licenses
44 ln -s /usr/share/licenses/qt6-base "$pkgdir"/usr/share/licenses/$pkgname