db-move: moved polari from [testing] to [extra] (x86_64)
[arch-packages.git] / sushi / trunk / PKGBUILD
blob861d742504d267f86d85e3d1e1124a1b47e3d5f8
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Ionut Biru <ibiru@archlinux.org>
4 pkgname=sushi
5 pkgver=43.0
6 pkgrel=1
7 pkgdesc="A quick previewer for Nautilus"
8 url="https://gitlab.gnome.org/GNOME/sushi"
9 arch=(x86_64)
10 license=(GPL2)
11 groups=(gnome)
12 depends=(gtk3 gjs webkit2gtk-4.1 gtksourceview4 evince gst-plugins-base-libs
13          gst-plugin-gtk libsoup3)
14 makedepends=(gobject-introspection git meson)
15 optdepends=('unoconv: OpenDocument formats')
16 _commit=515ea522250689a035d346d919e97fb6f62b0518  # tags/43.0^0
17 source=("git+https://gitlab.gnome.org/GNOME/sushi.git#commit=$_commit")
18 sha256sums=('SKIP')
20 pkgver() {
21   cd sushi
22   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
25 prepare() {
26   cd sushi
29 build() {
30   arch-meson sushi build
31   meson compile -C build
34 check() {
35   meson test -C build --print-errorlogs
38 package() {
39   meson install -C build --destdir "$pkgdir"
42 # vim:set sw=2 sts=-1 et: