db-move: moved polari from [testing] to [extra] (x86_64)
[arch-packages.git] / w3m / repos / extra-x86_64 / PKGBUILD
blob5430b76c0f40a5afad8e86a6e6e7894a3de92fcc
1 # Maintainer: Gaetan Bisson <bisson@archlinux.org>
2 # Contributor: dorphell <dorphell@archlinux.org>
4 pkgname=w3m
5 _gitcommit=fee038d7180e3d69276f55167a0d1da5233bc9c2
6 _pkgver=0.5.3.git20230121-1
7 pkgver=${_pkgver/-/_}
8 pkgrel=1
9 pkgdesc='Text-based Web browser as well as pager'
10 url='https://salsa.debian.org/debian/w3m'
11 license=('custom')
12 arch=('x86_64')
13 makedepends=('git' 'imlib2')
14 optdepends=('imlib2: for graphics support')
15 depends=('openssl' 'gc' 'ncurses' 'gpm')
16 source=("git+https://salsa.debian.org/debian/w3m.git#commit=${_gitcommit}")
17 sha256sums=('SKIP')
19 # There's also the maintainer's github repo, usually in sync with Debian's:
20 # https://github.com/tats/w3m
22 build() {
23   cd ${pkgname}
24   ./configure \
25     --prefix=/usr \
26     --libexecdir=/usr/lib \
27     --enable-image=x11,fb \
28     --with-imagelib=imlib2 \
29     --with-termlib=ncurses \
30     --disable-w3mmailer \
32   make
35 package() {
36   cd ${pkgname}
37   make DESTDIR="${pkgdir}" install
39   install -d "${pkgdir}"/usr/share/{doc,licenses}/w3m
40   install -m644 doc/* "${pkgdir}/usr/share/doc/w3m"
41   ln -s ../../doc/w3m/README "${pkgdir}/usr/share/licenses/w3m"