1 # Maintainer: Andreas Radke <andyrtr@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
7 pkgdesc="A library which provides a secure layer over a reliable transport layer"
9 license=('GPL3' 'LGPL2.1')
10 url="https://www.gnutls.org/"
11 options=('!zipman' 'debug')
12 depends=('gcc-libs' 'libtasn1' 'readline' 'zlib' 'nettle' 'p11-kit' 'libidn2'
13 'libidn2.so' 'libunistring' 'brotli')
14 makedepends=('tpm2-tss')
15 checkdepends=('net-tools' 'tpm2-tools')
16 optdepends=('guile: for use with Guile bindings'
17 'tpm2-tss: support for TPM2 wrapped keys'
18 'zstd: for compression support')
19 source=(https://www.gnupg.org/ftp/gcrypt/gnutls/v3.7/${pkgname}-${pkgver}.tar.xz{,.sig})
20 sha256sums=('be9143d0d58eab64dba9b77114aaafac529b6c0d7e81de6bdf1c9b59027d2106'
22 #validpgpkeys=('462225C3B46F34879FC8496CD605848ED7E69871') # "Daiki Ueno <ueno@unixuser.org>"
23 validpgpkeys=('5D46CB0F763405A7053556F47A75A648B3F9220C') # "Zoltan Fridrich <zfridric@redhat.com>"
26 cd ${pkgname}-${pkgver}
27 ./configure --prefix=/usr \
33 --enable-openssl-compatibility \
34 --enable-guile --with-guile-site-dir=no \
35 --with-default-trust-store-pkcs11="pkcs11:"
36 # --enable-ktls \ # breaks testsuite
37 sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
42 cd ${pkgname}-${pkgver}
43 # disable parallel tests:
49 cd ${pkgname}-${pkgver}
50 make DESTDIR="${pkgdir}" install
52 # lots of .png files are put into infodir and are gzipped by makepkg! this needs to be fixed by using !zipman
53 # gzip -9 all files in infodir and manpages manually
54 find "$pkgdir/usr/share/info" -name '*.info*' -exec gzip -n -9 {} \;
55 find "$pkgdir/usr/share/man" -exec gzip -n -9 {} \;