OCaml 4.14.0 rebuild
[arch-packages.git] / gst-plugins-ugly / trunk / PKGBUILD
blob8b255413226fa6ebf79c0bf4da4bd499445f5d34
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
4 pkgname=gst-plugins-ugly
5 pkgver=1.18.5
6 pkgrel=3
7 pkgdesc="Multimedia graph framework - ugly plugins"
8 url="https://gstreamer.freedesktop.org/"
9 arch=(x86_64)
10 license=(LGPL)
11 depends=(gst-plugins-base-libs libdvdread libmpeg2 a52dec libsidplay libcdio
12          x264 opencore-amr)
13 makedepends=(python git meson)
14 _commit=bd1dfb44475ab04d42b217acdf90942e0b7893b5  # tags/1.18.5^0
15 source=("git+https://gitlab.freedesktop.org/gstreamer/gst-plugins-ugly.git#commit=$_commit")
16 sha256sums=('SKIP')
18 pkgver() {
19   cd $pkgname
20   git describe --tags | sed 's/-/+/g'
23 prepare() {
24   cd $pkgname
27 build() {
28   arch-meson $pkgname build \
29     -D doc=disabled \
30     -D gobject-cast-checks=disabled \
31     -D package-name="GStreamer Ugly Plugins (Arch Linux)" \
32     -D package-origin="https://www.archlinux.org/"
33   meson compile -C build
36 check() {
37   meson test -C build --print-errorlogs
40 package() {
41   meson install -C build --destdir "$pkgdir"