db-move: moved webkit2gtk from [testing] to [extra] (x86_64)
[arch-packages.git] / cpdb-backend-file / trunk / PKGBUILD
blob31021901cd864bec0d42de421a55ade338db6ce8
1 # Maintainer: Andreas Radke <andyrtr@archlinux.org>
3 pkgname=cpdb-backend-file
4 pkgver=2.0b1
5 pkgrel=1
6 epoch=
7 pkgdesc="PDF file Backend for the common print dialog "
8 arch=('x86_64')
9 url="https://github.com/OpenPrinting/cpdb-backend-file"
10 license=('MIT')
11 depends=('cpdb-libs')
12 source=($url/releases/download/$pkgver/cpdb-backend-file-$pkgver.tar.gz)
13 sha256sums=('768ce09a9686e7d58f276ca7ce8eeb8f97d4b51355300a22e2b93ca0c50dc0d0')
14 #validpgpkeys=()
16 build() {
17   cd "$pkgname-$pkgver"
18   ./configure --prefix=/usr
19   make
22 check() {
23   cd "$pkgname-$pkgver"
24   make -k check
27 package() {
28   cd "$pkgname-$pkgver"
29   make DESTDIR="$pkgdir/" install
30   install -Dm644 LICENSE.md "$pkgdir"/usr/share/licenses/$pkgname/LICENSE