db-move: moved webkit2gtk from [testing] to [extra] (x86_64)
[arch-packages.git] / gnome-calendar / trunk / PKGBUILD
blob51b0fcb477e8830c30f860c3578a4936734fb4c3
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
4 pkgname=gnome-calendar
5 pkgver=44.1
6 pkgrel=1
7 pkgdesc="Simple and beautiful calendar application designed to perfectly fit the GNOME desktop"
8 url="https://wiki.gnome.org/Apps/Calendar"
9 arch=(x86_64)
10 license=(GPL)
11 depends=(
12   evolution-data-server
13   geoclue
14   geocode-glib-2
15   gsettings-desktop-schemas
16   libadwaita
17   libedataserverui4
18   libgweather-4
19   libsoup3
21 makedepends=(
22   git
23   meson
25 optdepends=('gnome-control-center: Manage online accounts')
26 groups=(gnome)
27 _commit=0d0ef588ad192094c63b73d768a8a01d091d61a7  # tags/44.1^0
28 source=("git+https://gitlab.gnome.org/GNOME/gnome-calendar.git#commit=$_commit")
29 b2sums=('SKIP')
31 pkgver() {
32   cd $pkgname
33   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
36 prepare() {
37   cd $pkgname
40 build() {
41   arch-meson $pkgname build
42   meson compile -C build
45 check() {
46   meson test -C build --print-errorlogs
49 package() {
50   meson install -C build --destdir "$pkgdir"
53 # vim:set sw=2 sts=-1 et: