db-move: moved webkit2gtk from [testing] to [extra] (x86_64)
[arch-packages.git] / kdsoap / trunk / PKGBUILD
blob4dbc0b0089ea572b29cb9adbd53f1cb8bed156f2
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
2 # Contributor: drakkan <nicola.murino at gmail dot com>
4 pkgname=kdsoap
5 pkgver=2.1.1
6 pkgrel=1
7 pkgdesc='Qt-based client-side and server-side SOAP component'
8 license=(GPL3 LGPL custom)
9 arch=(x86_64)
10 url='https://github.com/KDAB/KDSoap'
11 depends=(qt5-base)
12 makedepends=(cmake)
13 source=(https://github.com/KDAB/KDSoap/releases/download/$pkgname-$pkgver/$pkgname-$pkgver.tar.gz{,.asc})
14 sha256sums=('aed57f6b200ddf762f5d2898f7e9228dd0700881c4491aefe4006f7fa5f5c627'
15             'SKIP')
16 validpgpkeys=(E86C000370B1B9E2A9191AD53DBFB6882C9358FB) # KDAB Products (user for KDAB products) <info@kdab.com>
18 build() {
19   cmake -B build -S $pkgname-$pkgver \
20     -DCMAKE_INSTALL_PREFIX=/usr \
21     -DCMAKE_BUILD_TYPE=None
22   cmake --build build
25 package() {
26   DESTDIR="$pkgdir" cmake --install build
27   install -Dm644 $pkgname-$pkgver/LICENSE.txt -t "$pkgdir"/usr/share/licenses/$pkgname