db-move: moved webkit2gtk from [testing] to [extra] (x86_64)
[arch-packages.git] / perl-appconfig / trunk / PKGBUILD
blob89c4f507d9e35f88e874fbeeeb58169f2b5e106e
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: eric <eric@archlinux.org>
3 # Contributor: Eric Johnson <eric@coding-zone.com>
5 pkgname=perl-appconfig
6 pkgver=1.71
7 pkgrel=10
8 pkgdesc="Perl/CPAN AppConfig module - Read configuration files and parse command line arguments"
9 arch=('any')
10 license=('PerlArtistic' 'GPL')
11 url="https://search.cpan.org/dist/AppConfig/"
12 depends=('perl')
13 options=('!emptydirs')
14 source=("https://www.cpan.org/authors/id/N/NE/NEILB/AppConfig-$pkgver.tar.gz")
15 sha256sums=('1177027025ecb09ee64d9f9f255615c04db5e14f7536c344af632032eb887b0f')
17 build() {
18   cd AppConfig-$pkgver
19   perl Makefile.PL INSTALLDIRS=vendor
20   make
23 check() {
24   cd AppConfig-$pkgver
25   make test
28 package() {
29   cd AppConfig-$pkgver
30   make install DESTDIR="$pkgdir"