1 # Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
2 # Contributor: Daniel Isenmann <daniel@archlinux.org>
3 # Contributor: Sergej Pupykin <sergej@aur.archlinux.org>
4 # Contributor: Douglas Soares de Andrade <dsandrade@gmail.com>
8 pkgver=2.1.2.r56.gabc098c
9 # somewhere past 2.1.2 as there has not been a release in years to have Python 3.11 support without bricking dependents
10 # https://github.com/urwid/urwid/issues/511
11 # https://github.com/urwid/urwid/issues/548
12 # https://github.com/urwid/urwid/issues/550
13 _commit=abc098c3400220b51aeb6fec14175e1bfa1f8bfb
15 pkgdesc='Curses-based user interface library'
16 url='https://urwid.org/'
22 'python-typing-extensions'
32 git+https://github.com/$_name/$_name.git#commit=$_commit
39 git describe --long --abbrev=7 | sed 's/^release-//;s/\([^-]*-g\)/r\1/;s/-/./g'
44 python -m build --wheel --no-isolation
49 python -m unittest discover -vs $_name/tests
54 python -m installer --destdir="$pkgdir" dist/*.whl
55 rm -rv "${pkgdir}"/usr/lib/python*/site-packages/urwid/tests