db-move: moved webkit2gtk from [testing] to [extra] (x86_64)
[arch-packages.git] / qt5-script / trunk / PKGBUILD
blob988d18500d8faa8d0bdc8735b1e88957f9f36ebc
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Andrea Scarpino <andrea@archlinux.org>
4 pkgname=qt5-script
5 _basever=5.15.9
6 pkgver=5.15.13
7 pkgrel=2
8 arch=('x86_64')
9 url='https://www.qt.io'
10 license=('GPL3' 'LGPL3' 'FDL' 'custom')
11 pkgdesc='Classes for making Qt applications scriptable. Provided for Qt 4.x compatibility'
12 depends=('qt5-base')
13 makedepends=('git')
14 groups=('qt' 'qt5')
15 _pkgfqn=${pkgname/5-/}
16 source=(git+https://code.qt.io/qt/$_pkgfqn.git#tag=v${pkgver}-lts)
17 sha256sums=('SKIP')
18 options=(!lto)
20 prepare() {
21   mkdir -p build
24 build() {
25   cd build
27 # Disable LTO, see FS#73264
28   qmake ../${_pkgfqn} CONFIG-=ltcg
29   make
32 package() {
33   cd build
34   make INSTALL_ROOT="$pkgdir" install
36   # Drop QMAKE_PRL_BUILD_DIR because reference the build dir
37   find "$pkgdir/usr/lib" -type f -name '*.prl' \
38     -exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;
40   install -d "$pkgdir"/usr/share/licenses
41   ln -s /usr/share/licenses/qt5-base "$pkgdir"/usr/share/licenses/${pkgname}
43   # Fix cmake dependency versions
44   sed -e "s|$pkgver\ |$_basever |" -i "$pkgdir"/usr/lib/cmake/*/*Config.cmake