db-move: moved webkit2gtk from [testing] to [extra] (x86_64)
[arch-packages.git] / seahorse / repos / extra-x86_64 / PKGBUILD
blobf6330c4a2e421777666ad89601a013a1e62b40a5
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
3 # Contributor: Michel Brabants <michel.linux@tiscali.be>
5 pkgname=seahorse
6 pkgver=43.0
7 pkgrel=2
8 epoch=1
9 pkgdesc="GNOME application for managing PGP keys."
10 url="https://wiki.gnome.org/Apps/Seahorse"
11 arch=(x86_64)
12 license=(GPL)
13 depends=(
14   gcr
15   gpgme
16   gtk3
17   libhandy
18   libpwquality
19   libsecret
20   libsoup3
21   org.freedesktop.secrets
23 makedepends=(
24   git
25   gobject-introspection
26   libldap
27   meson
28   vala
29   yelp-tools
31 provides=(x11-ssh-askpass)
32 groups=(gnome-extra)
33 _commit=5303f3ff9b3ce69c7e88ee4678328b8ce892ccdb  # tags/43.0^0
34 source=("git+https://gitlab.gnome.org/GNOME/seahorse.git#commit=$_commit")
35 b2sums=('SKIP')
37 pkgver() {
38   cd seahorse
39   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
42 prepare() {
43   cd seahorse
46 build() {
47   arch-meson seahorse build -D manpage=true
48   meson compile -C build
51 check() {
52   meson test -C build --print-errorlogs
55 package() {
56   meson install -C build --destdir "$pkgdir"
59 # vim:set sw=2 sts=-1 et: