1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Eric Bélanger <eric@archlinux.org>
11 pkgdesc="Web content engine for GTK"
12 url="https://webkitgtk.org"
80 $url/releases/webkitgtk-$pkgver.tar.xz{,.asc}
82 sha256sums=('64e526984f8cd2161ef03ae949af99c002ff333d615e6386b460164a3c1b7ef6'
85 'D7FCF61CF9A2DEAB31D81BD3F3D322D0EC4582C3' # Carlos Garcia Campos <cgarcia@igalia.com>
86 '5AA3BC334FD7E3369E7C77B291C559DBE4C9123B' # Adrián Pérez de Castro <aperez@igalia.com>
96 -DCMAKE_BUILD_TYPE=Release
97 -DCMAKE_INSTALL_PREFIX=/usr
98 -DCMAKE_INSTALL_LIBDIR=lib
99 -DCMAKE_INSTALL_LIBEXECDIR=lib
100 -DCMAKE_SKIP_RPATH=ON
103 -DENABLE_DOCUMENTATION=ON
104 -DENABLE_MINIBROWSER=ON
107 # Produce minimal debug info: 4.3 GB of debug data makes the
108 # build too slow and is too much to package for debuginfod
112 cmake -S webkitgtk-$pkgver -B build -G Ninja "${cmake_options[@]}"
116 package_webkitgtk-6.0() {
118 libWPEBackend-fdo-1.0.so
122 libjavascriptcoregtk-6.0.so
126 'geoclue: Geolocation support'
127 'gst-libav: nonfree media decoding'
128 'gst-plugins-bad: media decoding'
129 'gst-plugins-good: media decoding'
132 DESTDIR="$pkgdir" cmake --install build
134 mkdir -p doc/usr/share
135 mv {"$pkgdir",doc}/usr/share/gtk-doc
138 find Source -name 'COPYING*' -or -name 'LICENSE*' -print0 | sort -z |
139 while IFS= read -d $'\0' -r _f; do
144 install -Dm644 /dev/stdin "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
147 package_webkitgtk-6.0-docs() {
148 pkgdesc+=" (documentation)"
154 # vim:set sw=2 sts=-1 et: