1 # Maintainer: David Runge <dvzrv@archlinux.org>
2 # Contributor: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
3 # Contributor: Mirco Tischler <mt-ml at gmx dot de>
6 _commit=ecd00a3e1977c9193ea0b27669234fa5669dfe7c # tags/v2023.2
9 pkgdesc="Operating system and container binary deployment and upgrades"
10 url="https://ostreedev.github.io/ostree/"
12 license=(custom:LGPL2)
50 provides=(libostree-1.so)
52 git+https://github.com/ostreedev/ostree#tag=$_commit
53 git+https://github.com/mendsley/bsdiff
54 git+https://gitlab.gnome.org/GNOME/libglnx.git
55 $pkgname-2023.1-use_fuse3.patch
60 'cfff162120f70995e18ec56454711501391b97456e2a0f34643c9d2a9c2b50b4d76afc2e2fc50ea28e8a773c618215d6cb855b96663f69dc5cc93bc5766f3f28')
61 # upstream ticket about chain of trust:
62 # https://github.com/ostreedev/ostree/issues/2349
63 validpgpkeys=('1CEC7A9DF7DA85ABEF843DC0A866D7CCAE087291') # Colin Walters <walters@redhat.com>
69 git cherry-pick -n 376c9d7effa01fa020711a3f12829fe9b18b8bca \
70 813c439352297622e74a288aadf3cd700d19bc2f
72 # use fusemount3 (fuse3)
73 git apply -3 ../$pkgname-2023.1-use_fuse3.patch
75 # remove failing test: https://github.com/ostreedev/ostree/issues/2790
76 sed -e '/test-signed-pull-summary.sh/d' -i Makefile-tests.am
79 git submodule set-url bsdiff "$srcdir/bsdiff"
80 git submodule set-url libglnx "$srcdir/libglnx"
81 git -c protocol.file.allow=always submodule update
83 NOCONFIGURE=1 ./autogen.sh
87 local configure_options=(
94 --enable-experimental-api
96 --with-builtin-grub2-mkconfig
99 --with-ed25519-libsodium
105 ./configure "${configure_options[@]}"
106 # prevent overlinking due to libtool
107 sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
112 make check -k -C $pkgname
117 avahi libavahi-client.so libavahi-common.so libavahi-glib.so
119 glib2 libgio-2.0.so libglib-2.0.so libgobject-2.0.so
121 libarchive libarchive.so
122 libsoup libsoup-2.4.so
124 systemd-libs libsystemd.so
128 make DESTDIR="$pkgdir" install -C $pkgname
129 install -vDm 644 $pkgname/COPYING -t "$pkgdir/usr/share/licenses/$pkgname/"