archrelease: copy trunk to extra-x86_64
[arch-packages.git] / d-spy / trunk / PKGBUILD
blobb72a1922d6f79b7f54851ac8679b9229cc3f4ac2
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
3 pkgname=d-spy
4 pkgver=1.4.0
5 pkgrel=1
6 pkgdesc="D-Bus debugger for GNOME"
7 url="https://gitlab.gnome.org/GNOME/d-spy"
8 arch=(x86_64)
9 license=(GPL3 LGPL3)
10 depends=(gtk4 libadwaita)
11 makedepends=(git meson)
12 provides=(libdspy-1.so)
13 options=(debug)
14 _commit=687dc766770a0938e72fd747308f13a460b5a76f  # tags/1.4.0^0
15 source=("git+https://gitlab.gnome.org/GNOME/d-spy.git#commit=$_commit")
16 sha256sums=('SKIP')
18 pkgver() {
19   cd d-spy
20   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
23 build() {
24   arch-meson d-spy build
25   meson compile -C build
28 check() {
29   meson test -C build --print-errorlogs
32 package() {
33   meson install -C build --destdir "$pkgdir"
36 # vim:set sw=2 sts=-1 et: