1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Ionut Biru <ibiru@archlinux.org>
3 # Contributor: Hugo Doria <hugo@archlinux.org>
6 pkgname=(deluge deluge-gtk)
10 pkgdesc="BitTorrent client with multiple user interfaces in a client/server model"
11 url="https://deluge-torrent.org/"
16 'python-twisted>=17.1' python-service-identity python-idna
19 'python-rencode>=1.0.2'
21 'python-zope-interface>=4.4.2'
28 'libtorrent-rasterbar>=1.1.1'
47 _commit=0b5f45b486e8e974ba8a0b1d6e8edcd124fca62a # tags/deluge-2.1.1^0
48 source=("git+https://git.deluge-torrent.org/deluge#commit=$_commit")
53 git describe --tags | sed 's/^deluge-//;s/\.dev0-/dev/;s/-/+/g'
66 local p="$1" f d; shift
68 d="$srcdir/$p/${f#$pkgdir/}"
69 mkdir -p "$(dirname "$d")"
71 rmdir -p --ignore-fail-on-non-empty "$(dirname "$f")"
77 python setup.py install --root="$pkgdir" --optimize=1 --skip-build
79 install -Dt "$pkgdir/usr/lib/systemd/system" \
80 -m644 packaging/systemd/*.service
81 install -Dt "$pkgdir/usr/lib/systemd/user" \
82 -m644 packaging/systemd/user/*.service
83 install -Dt "$pkgdir/usr/lib/systemd/system/deluged.service.d" \
84 -m644 packaging/systemd/user.conf
85 install -Dt "$pkgdir/usr/lib/systemd/system/deluge-web.service.d" \
86 -m644 packaging/systemd/user.conf
88 echo 'u deluge - "Deluge BitTorrent daemon" /srv/deluge' |
89 install -Dm644 /dev/stdin "$pkgdir/usr/lib/sysusers.d/$pkgname.conf"
90 echo 'd /srv/deluge 0770 deluge deluge' |
91 install -Dm644 /dev/stdin "$pkgdir/usr/lib/tmpfiles.d/$pkgname.conf"
95 _pick gtk usr/bin/deluge-gtk usr/share/man/man1/deluge-gtk.1
96 _pick gtk usr/share/{appdata,applications,icons,pixmaps}
97 _pick gtk usr/lib/python3.10/site-packages/deluge/ui/gtk3
100 package_deluge-gtk() {
101 pkgdesc="GTK UI for Deluge"
103 "deluge=$epoch:$pkgver-$pkgrel"
111 'libappindicator-gtk3: appindicator notifications'
112 'python-pygame: audible notifications'
113 'libnotify: desktop notifications'
115 replaces=('deluge<2.0.4.dev23+g2f1c008a2-2')