archrelease: copy trunk to extra-x86_64
[arch-packages.git] / four-in-a-row / trunk / PKGBUILD
blob986e72de341bccefc0d76ef420ef368ae43cf4b3
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
4 pkgname=four-in-a-row
5 pkgver=3.38.1
6 pkgrel=1
7 pkgdesc="Make lines of the same color to win"
8 url="https://wiki.gnome.org/Apps/Four-in-a-row"
9 arch=(x86_64)
10 license=(GPL3)
11 depends=(gtk3 gsound librsvg)
12 makedepends=(meson gobject-introspection yelp-tools appstream-glib vala git)
13 groups=(gnome-extra)
14 _commit=462f1096fc8876bb70c9ef2a615054822589320a  # tags/3.38.1^0
15 source=("git+https://gitlab.gnome.org/GNOME/four-in-a-row.git#commit=$_commit")
16 sha256sums=('SKIP')
18 pkgver() {
19   cd $pkgname
20   git describe --tags | sed 's/-/+/g'
23 prepare() {
24   cd $pkgname
27 build() {
28   arch-meson $pkgname build
29   meson compile -C build
32 check() {
33   meson test -C build --print-errorlogs
36 package() {
37   DESTDIR="$pkgdir" meson install -C build