archrelease: copy trunk to extra-x86_64
[arch-packages.git] / gtk-engines / trunk / PKGBUILD
blob1031523f47211051a2031469688df236052d0896
1 # Maintainer: Jan de Groot <jgc@archlinux.org>
3 pkgname=gtk-engines
4 pkgver=2.21.0
5 pkgrel=5
6 pkgdesc="Theme engines for GTK+ 2"
7 arch=(x86_64)
8 license=('GPL' 'LGPL')
9 depends=('gtk2>=2.24.0')
10 makedepends=('pkg-config' 'intltool' 'gnome-common' 'git')
11 url="http://live.gnome.org/GnomeArt"
12 conflicts=('lighthouse-gtk2' 'clearlooks-gtk2')
13 replaces=('lighthouse-gtk2')
14 source=('git+https://gitlab.gnome.org/Archive/gtk-engines.git#commit=e23eb81ade8c815dcd4da026ab7a2b7307a4f326')
15 sha256sums=('SKIP')
17 prepare() {
18   cd $pkgname
19   NOCONFIGURE=1 ./autogen.sh
22 build() {
23   cd $pkgname
24   ./configure --prefix=/usr --enable-animation
25   sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
26   make
29 package() {
30   cd $pkgname
31   make DESTDIR="${pkgdir}" install