archrelease: copy trunk to extra-x86_64
[arch-packages.git] / python-pyopenssl / repos / extra-any / PKGBUILD
blob9ba3e6a9ea7b88b2405974f97886278361b25c1d
1 # Maintainer : Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Ionut Biru <ibiru@archlinux.org>
3 # Contributor: Sergej Pupykin <pupykin.s+arch@gmail.com>
5 pkgname=python-pyopenssl
6 pkgver=23.0.0
7 pkgrel=1
8 arch=('any')
9 pkgdesc="Python3 wrapper module around the OpenSSL library"
10 url='https://github.com/pyca/pyopenssl'
11 license=('Apache')
12 depends=('python-cryptography')
13 makedepends=('python-setuptools')
14 checkdepends=('python-pytest' 'python-pretend' 'python-flaky')
15 source=(https://github.com/pyca/pyopenssl/archive/$pkgver/$pkgname-$pkgver.tar.gz)
16 sha512sums=('3f2db2d1f59e53763e3c39f5ca941d9dc3974edbdb9094f53d8c88923119449165f4277da6eb7a04c66e83bedc899ad60c5225f5aaa473b38f56801789f86164')
18 prepare() {
19   export LC_CTYPE=en_US.UTF-8
22 build() {
23   cd pyopenssl-$pkgver
24   python setup.py build
27 check() {
28   cd pyopenssl-$pkgver
29   PYTHONPATH="$PWD"/build/lib pytest
32 package() {
33   cd pyopenssl-$pkgver
34   python setup.py install --root="$pkgdir" --optimize=1 --skip-build
37 # vim: ts=2 sw=2 et: